Home » Infrastructure » Windows » unable to run preupgrade.jar - getting invalid username/password error (Oracle 12C to 18c)
unable to run preupgrade.jar - getting invalid username/password error [message #678581] Tue, 17 December 2019 01:36 Go to next message
kurki
Messages: 17
Registered: December 2013
Junior Member
Hi All,

I an trying to upgrade oracle 12c version to 18c. I have extracted 18C binaries and installed 18C.
while running preupgrade.jar, Getting the below.


C:\Users\Ramkidba>\java -jar D:\app\oradb\product\18.0.0\rdbms\admin\preupgrade.jar TERMINAL TEXT
ERROR - Unable to run preupgrade due to:
ERROR:
ORA-01017: invalid username/password; logon denied


SP2-0751: Unable to connect to Oracle. Exiting SQL*Plus

Please advise.


Thanks,
Sriram
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678583 is a reply to message #678581] Tue, 17 December 2019 01:48 Go to previous messageGo to next message
John Watson
Messages: 8390
Registered: January 2010
Location: Global Village
Senior Member
To what are the variables ORACLE_HOME, ORACE_SID, and PATH set?
What groups is your Windows user a member of?
What users are the 12.x home and the 18.x home installed under?
What Windows login is the Oracle instance service using?

[Updated on: Tue, 17 December 2019 01:49]

Report message to a moderator

Re: unable to run preupgrade.jar - getting invalid username/password error [message #678584 is a reply to message #678583] Tue, 17 December 2019 02:25 Go to previous messageGo to next message
kurki
Messages: 17
Registered: December 2013
Junior Member
Hi,

Thanks for your quick reply.

ORACLE_HOME is set to 12C O_H
ORACLe_SID is also set 12c database which is existing one.
and PATH I have set to 12c bin directory. If I set to 18c also same issue.

Windows user is a domain user not the local users.
and 12c installation user is different comparing to 18c installation user.

Oracle instance service using with different user oradb which is not the same as installation user of 12c.

Thanks,
Sriram



Re: unable to run preupgrade.jar - getting invalid username/password error [message #678585 is a reply to message #678584] Tue, 17 December 2019 02:27 Go to previous messageGo to next message
John Watson
Messages: 8390
Registered: January 2010
Location: Global Village
Senior Member
And you group memberships? The local ORA_DBA group, and all the others?
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678586 is a reply to message #678585] Tue, 17 December 2019 02:32 Go to previous messageGo to next message
kurki
Messages: 17
Registered: December 2013
Junior Member
Hi,

There are a few groups related to Oracle, ORA_DBA, ORA_ASM and ORA_INSTALL
and oradb user is part of all the above groups but not a member in some of the ORA_* groups.


Thanks,
Sriram
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678587 is a reply to message #678586] Tue, 17 December 2019 02:59 Go to previous messageGo to next message
John Watson
Messages: 8390
Registered: January 2010
Location: Global Village
Senior Member
I asked what groups your user, ie the person running the preupgrade, is a member of.
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678589 is a reply to message #678587] Tue, 17 December 2019 04:18 Go to previous messageGo to next message
kurki
Messages: 17
Registered: December 2013
Junior Member
Hi,

As this is a active directory user and not a local user I am unable to check which group(s) he is belongs to.
Will check and update you.


Thanks,
Sriram
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678590 is a reply to message #678589] Tue, 17 December 2019 04:47 Go to previous messageGo to next message
John Watson
Messages: 8390
Registered: January 2010
Location: Global Village
Senior Member
Are you saying that you cannot run

whoami /groups

?
Re: unable to run preupgrade.jar - getting invalid username/password error [message #678596 is a reply to message #678590] Tue, 17 December 2019 12:48 Go to previous message
kurki
Messages: 17
Registered: December 2013
Junior Member
Hi,

Issue has been resolved.
The problem is with the owner of the oracle.exe executable.
Changed ownership as per the oracle 12c installation and the issue resolved


Thanks a lot for your time and help.

Thanks,
Sriram
Previous Topic: Network permissions when using Windows virtual account
Next Topic: Upgrading from 12c to 18c failing with error: database already upgraded
Goto Forum:
  


Current Time: Wed Oct 21 20:31:45 CDT 2020